iceweasel fails to launch after kernel upgrade

If after upgrading to kernel version 16 or above ,iceweasel fails to launch, try launching it from the command line using the command

If you see the following error in the terminal

It means that the iceweasel needs to be upgraded. We can do that easily from the package manager. Just open the package manager search for the package iceweasel. Right click on the package and selcet "mark for upgrade" and then click on apply.

Once iceweasel is upgraded the above error should not come.

Can not create /sys/kernel/uevent_helper Permission denied

While compiling 3.16 kernels, we might hit the error

Can not create /sys/kernel/uevent_helper Permission denied.

The reason for this could be that the the config option

is not set.

Open the .config file, search for CONFIG_UEVENT_HELPER and set it to "y".

Save the .config file and recompile the kernel and boot it. The above error should not occur.

Cannot execute init (error 8)

If we hit the error

while booting a freshely compiled kernel, then the possible reason could be that we have forgotten to enable the confiog option

Open the .config file, search for the above option and if it is set to "n" or is not set then change it to

Save the file, and recompile the kernel. The above error should not appear now.

Follow by Email